# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(".*)(,)(\s.*")/$1<!>$3/gi;t' <<< "peter@pan.com, lucky <jack@pot.com>, \"William Tell\" <billy@tell.com>, \"John Rambo, III\" <johnny@rambo.com>, \"there, might, be, several, commas inside the quotes\" <multiple@commas.com>,
\"yes, this is also a valid email address, can you believe\" <yes@this@is@valid.com>
"