using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("".*)(,)(\s.*"")";
string substitution = @"$1<!>$3";
string input = @"peter@pan.com, lucky <jack@pot.com>, ""William Tell"" <billy@tell.com>, ""John Rambo, III"" <johnny@rambo.com>, ""there, might, be, several, commas inside the quotes"" <multiple@commas.com>,
""yes, this is also a valid email address, can you believe"" <yes@this@is@valid.com>
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}