import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\".*)(,)(\\s.*\")";
final String string = "peter@pan.com, lucky <jack@pot.com>, \"William Tell\" <billy@tell.com>, \"John Rambo, III\" <johnny@rambo.com>, \"there, might, be, several, commas inside the quotes\" <multiple@commas.com>, \n"
+ "\"yes, this is also a valid email address, can you believe\" <yes@this@is@valid.com>\n";
final String subst = "$1<!>$3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}