re = /(".*)(,)(\s.*")/i
str = 'peter@pan.com, lucky <jack@pot.com>, "William Tell" <billy@tell.com>, "John Rambo, III" <johnny@rambo.com>, "there, might, be, several, commas inside the quotes" <multiple@commas.com>,
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>
'
subst = '$1<!>$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result