import re
regex = re.compile(r"(\".*)(,)(\s.*\")", flags=re.IGNORECASE)
test_str = ("peter@pan.com, lucky <jack@pot.com>, \"William Tell\" <billy@tell.com>, \"John Rambo, III\" <johnny@rambo.com>, \"there, might, be, several, commas inside the quotes\" <multiple@commas.com>, \n"
"\"yes, this is also a valid email address, can you believe\" <yes@this@is@valid.com>\n")
subst = "$1<!>$3"
result = regex.sub(subst, test_str)
if result:
print(result)