#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(".*)(,)(\s.*")"
Local $sString = "peter@pan.com, lucky <jack@pot.com>, "William Tell" <billy@tell.com>, "John Rambo, III" <johnny@rambo.com>, "there, might, be, several, commas inside the quotes" <multiple@commas.com>, " & @CRLF & _
""yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>" & @CRLF & _
""
Local $sSubst = "$1<!>$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)