#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/(?P<lang>[\w]{2})/(?P<citySlug>[\w-]{1,100})-d(?P<cityId>[0-9]{1,10})/(?P<productSlug>[\w-]{1,100})-p(?P<productId>[0-9]{1,10})"
Local $sString = "/en/barcelona-d1/el-born--picasso-museum-p19/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")