const regex = new RegExp('/(?P<lang>[\\w]{2})/(?P<citySlug>[\\w-]{1,100})-d(?P<cityId>[0-9]{1,10})/(?P<productSlug>[\\w-]{1,100})-p(?P<productId>[0-9]{1,10})', '')
const str = `/en/barcelona-d1/el-born--picasso-museum-p19/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}