use strict;
my $str = '/en/barcelona-d1/el-born--picasso-museum-p19/';
my $regex = qr//(?P<lang>[\w]{2})/(?P<citySlug>[\w-]{1,100})-d(?P<cityId>[0-9]{1,10})/(?P<productSlug>[\w-]{1,100})-p(?P<productId>[0-9]{1,10})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}