import Foundation
let pattern = #"/(?P<lang>[\w]{2})/(?P<citySlug>[\w-]{1,100})-d(?P<cityId>[0-9]{1,10})/(?P<productSlug>[\w-]{1,100})-p(?P<productId>[0-9]{1,10})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/en/barcelona-d1/el-born--picasso-museum-p19/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}