import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/(?P<lang>[\\w]{2})/(?P<citySlug>[\\w-]{1,100})-d(?P<cityId>[0-9]{1,10})/(?P<productSlug>[\\w-]{1,100})-p(?P<productId>[0-9]{1,10})";
final String string = "/en/barcelona-d1/el-born--picasso-museum-p19/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}