re = /\/(?P<lang>[\w]{2})\/(?P<citySlug>[\w-]{1,100})-d(?P<cityId>[0-9]{1,10})\/(?P<productSlug>[\w-]{1,100})-p(?P<productId>[0-9]{1,10})/
str = '/en/barcelona-d1/el-born--picasso-museum-p19/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end