using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/(?P<lang>[\w]{2})/(?P<citySlug>[\w-]{1,100})-d(?P<cityId>[0-9]{1,10})/(?P<productSlug>[\w-]{1,100})-p(?P<productId>[0-9]{1,10})";
string input = @"/en/barcelona-d1/el-born--picasso-museum-p19/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}