#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.(([cm]?j|t)sx?|json)$"
Local $sString = "bla.cjs" & @CRLF & _
"bla.js" & @CRLF & _
"bla.json" & @CRLF & _
"bla.mjs" & @CRLF & _
"bla.ts" & @CRLF & _
"" & @CRLF & _
"bla.css" & @CRLF & _
"bla.html" & @CRLF & _
"bla.scss" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")