import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(([cm]?j|t)sx?|json)$";
final String string = "bla.cjs\n"
+ "bla.js\n"
+ "bla.json\n"
+ "bla.mjs\n"
+ "bla.ts\n\n"
+ "bla.css\n"
+ "bla.html\n"
+ "bla.scss\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}