re = /\.(([cm]?j|t)sx?|json)$/m
str = 'bla.cjs
bla.js
bla.json
bla.mjs
bla.ts
bla.css
bla.html
bla.scss
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end