package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.(([cm]?j|t)sx?|json)$`)
var str = `bla.cjs
bla.js
bla.json
bla.mjs
bla.ts
bla.css
bla.html
bla.scss
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}