$re = '/\.(([cm]?j|t)sx?|json)$/m';
$str = 'bla.cjs
bla.js
bla.json
bla.mjs
bla.ts
bla.css
bla.html
bla.scss
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);