using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(([cm]?j|t)sx?|json)$";
string input = @"bla.cjs
bla.js
bla.json
bla.mjs
bla.ts
bla.css
bla.html
bla.scss
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}