const regex = /\.(([cm]?j|t)sx?|json)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(([cm]?j|t)sx?|json)$', 'gm')
const str = `bla.cjs
bla.js
bla.json
bla.mjs
bla.ts
bla.css
bla.html
bla.scss
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}