using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]+(?:[ `-][a-zA-Z]+)* ?$";
string input = @"Valid:
text-text
text text
text`text
text-text`text
text text-text
text`text text
--> INVALID
text``text text
text`text text
text`text -text
--> VALID
text
--> INVALID
text
`text
text`
-text
text-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}