import Foundation
let pattern = #"^[a-zA-Z]+(?:[ `-][a-zA-Z]+)* ?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Valid:
text-text
text text
text`text
text-text`text
text text-text
text`text text
--> INVALID
text``text text
text`text text
text`text -text
--> VALID
text
--> INVALID
text
`text
text`
-text
text-
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)