package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]+(?:[ `-][a-zA-Z]+)* ?$`)
var str = `Valid:
text-text
text text
text\`text
text-text\`text
text text-text
text\`text text
--> INVALID
text\`\`text text
text\`text text
text\`text -text
--> VALID
text
--> INVALID
text
\`text
text\`
-text
text-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}