use strict;
my $str = 'Valid:
text-text
text text
text`text
text-text`text
text text-text
text`text text
--> INVALID
text``text text
text`text text
text`text -text
--> VALID
text
--> INVALID
text
`text
text`
-text
text-';
my $regex = qr/^[a-zA-Z]+(?:[ `-][a-zA-Z]+)* ?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}