import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]+(?:[ `-][a-zA-Z]+)* ?$";
final String string = "Valid:\n"
+ "text-text\n"
+ "text text\n"
+ "text`text\n\n"
+ "text-text`text\n"
+ "text text-text\n"
+ "text`text text\n\n"
+ "--> INVALID\n"
+ "text``text text\n"
+ "text`text text\n"
+ "text`text -text\n\n"
+ " --> VALID\n"
+ "text \n"
+ " --> INVALID\n"
+ " text\n"
+ "`text\n"
+ "text`\n"
+ "-text\n"
+ "text-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}