$re = '/^[a-zA-Z]+(?:[ `-][a-zA-Z]+)* ?$/m';
$str = 'Valid:
text-text
text text
text`text
text-text`text
text text-text
text`text text
--> INVALID
text``text text
text`text text
text`text -text
--> VALID
text
--> INVALID
text
`text
text`
-text
text-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);