import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-G]{1}([5])?([#b]{1})?(mM|Mm|m|M|aug|dim|add)?([679]|11)?((sus)([24]))?";
final String string = "Am7\n\n"
+ "G9 Sm Dbm6\n"
+ "Eb7sus2 Bbm9\n\n"
+ "G7 Aaug Cdim6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}