const regex = /[A-G]{1}([5])?([#b]{1})?(mM|Mm|m|M|aug|dim|add)?([679]|11)?((sus)([24]))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-G]{1}([5])?([#b]{1})?(mM|Mm|m|M|aug|dim|add)?([679]|11)?((sus)([24]))?', 'gm')
const str = `Am7
G9 Sm Dbm6
Eb7sus2 Bbm9
G7 Aaug Cdim6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}