import re
regex = re.compile(r"[A-G]{1}([5])?([#b]{1})?(mM|Mm|m|M|aug|dim|add)?([679]|11)?((sus)([24]))?", flags=re.MULTILINE)
test_str = ("Am7\n\n"
"G9 Sm Dbm6\n"
"Eb7sus2 Bbm9\n\n"
"G7 Aaug Cdim6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")