package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([+-]?\d+.)?|.(\d+)?[Ee]?[+-]?\d+[fFlF]?`)
var str = `15.75
1.575E1
1575e-2
-2.5e-3
25E-4
10.0
10.0F
.0075e2
0.075e1
.075e1
75e-2
15.75f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}