import re
regex = re.compile(r"([+-]?\d+.)?|.(\d+)?[Ee]?[+-]?\d+[fFlF]?", flags=re.MULTILINE)
test_str = ("15.75\n"
"1.575E1\n"
"1575e-2\n"
"-2.5e-3\n"
"25E-4\n"
"10.0\n"
"10.0F\n"
".0075e2\n"
"0.075e1\n"
".075e1\n"
"75e-2\n"
"15.75f")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")