import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([+-]?\\d+.)?|.(\\d+)?[Ee]?[+-]?\\d+[fFlF]?";
final String string = "15.75\n"
+ "1.575E1\n"
+ "1575e-2\n"
+ "-2.5e-3\n"
+ "25E-4\n"
+ "10.0\n"
+ "10.0F\n"
+ ".0075e2\n"
+ "0.075e1\n"
+ ".075e1\n"
+ "75e-2\n"
+ "15.75f";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}