#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]+\d*[.,]*\d{0,2}$"
Local $sString = "12.34" & @CRLF & _
"12.340 //BAD - Zero cannot be the first character" & @CRLF & _
"12.345 //OK - I want 5 to be discarded" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Should Work" & @CRLF & _
"1" & @CRLF & _
"1.0" & @CRLF & _
"1.1" & @CRLF & _
"1.10" & @CRLF & _
"1.11" & @CRLF & _
"11.11" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Should not work" & @CRLF & _
"0" & @CRLF & _
"0.0" & @CRLF & _
"0.1" & @CRLF & _
"01" & @CRLF & _
"01.0" & @CRLF & _
"01.11" & @CRLF & _
"1.111" & @CRLF & _
"1.110" & @CRLF & _
"11.111" & @CRLF & _
"11.111111111111" & @CRLF & _
"1.1.1" & @CRLF & _
"1.112.22" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")