import Foundation
let pattern = #"^[1-9]+\d*[.,]*\d{0,2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12.34
12.340 //BAD - Zero cannot be the first character
12.345 //OK - I want 5 to be discarded
Should Work
1
1.0
1.1
1.10
1.11
11.11
Should not work
0
0.0
0.1
01
01.0
01.11
1.111
1.110
11.111
11.111111111111
1.1.1
1.112.22
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)