import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]+\\d*[.,]*\\d{0,2}$";
final String string = "12.34\n"
+ "12.340 //BAD - Zero cannot be the first character\n"
+ "12.345 //OK - I want 5 to be discarded\n\n\n"
+ "Should Work\n"
+ "1\n"
+ "1.0\n"
+ "1.1\n"
+ "1.10\n"
+ "1.11\n"
+ "11.11\n\n\n"
+ "Should not work\n"
+ "0\n"
+ "0.0\n"
+ "0.1\n"
+ "01\n"
+ "01.0\n"
+ "01.11\n"
+ "1.111\n"
+ "1.110\n"
+ "11.111\n"
+ "11.111111111111\n"
+ "1.1.1\n"
+ "1.112.22\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}