const regex = /^[1-9]+\d*[.,]*\d{0,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]+\\d*[.,]*\\d{0,2}$', 'gm')
const str = `12.34
12.340 //BAD - Zero cannot be the first character
12.345 //OK - I want 5 to be discarded
Should Work
1
1.0
1.1
1.10
1.11
11.11
Should not work
0
0.0
0.1
01
01.0
01.11
1.111
1.110
11.111
11.111111111111
1.1.1
1.112.22
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}