# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[1-9]+\d*[.,]*\d{0,2}$"
test_str = ("12.34\n"
"12.340 //BAD - Zero cannot be the first character\n"
"12.345 //OK - I want 5 to be discarded\n\n\n"
"Should Work\n"
"1\n"
"1.0\n"
"1.1\n"
"1.10\n"
"1.11\n"
"11.11\n\n\n"
"Should not work\n"
"0\n"
"0.0\n"
"0.1\n"
"01\n"
"01.0\n"
"01.11\n"
"1.111\n"
"1.110\n"
"11.111\n"
"11.111111111111\n"
"1.1.1\n"
"1.112.22\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.