re = /^[1-9]+\d*[.,]*\d{0,2}$/m
str = '12.34
12.340 //BAD - Zero cannot be the first character
12.345 //OK - I want 5 to be discarded
Should Work
1
1.0
1.1
1.10
1.11
11.11
Should not work
0
0.0
0.1
01
01.0
01.11
1.111
1.110
11.111
11.111111111111
1.1.1
1.112.22
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end