use strict;
my $str = '12.34
12.340 //BAD - Zero cannot be the first character
12.345 //OK - I want 5 to be discarded
Should Work
1
1.0
1.1
1.10
1.11
11.11
Should not work
0
0.0
0.1
01
01.0
01.11
1.111
1.110
11.111
11.111111111111
1.1.1
1.112.22
';
my $regex = qr/^[1-9]+\d*[.,]*\d{0,2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}