#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([a-zA-Z0-9-_]{0,63}\.?[a-zA-Z0-9-_]{1,63}\.[a-zA-Z0-9-_]{1,63}):?(\d{1,5})?$"
Local $sString = ".com" & @CRLF & _
"a.com" & @CRLF & _
"aa.com" & @CRLF & _
"a.a.com" & @CRLF & _
"a.a.a.com" & @CRLF & _
"" & @CRLF & _
"Domain-123.com" & @CRLF & _
"subDomain.Domain-123.com" & @CRLF & _
"test.subDomain.Domain-123.com" & @CRLF & _
"" & @CRLF & _
"Domain-123.com:12345" & @CRLF & _
"subDomain.Domain-123.com:12345" & @CRLF & _
"test.subDomain.Domain-123.com:12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")