const regex = new RegExp('^([a-zA-Z0-9-_]{0,63}\\.?[a-zA-Z0-9-_]{1,63}\\.[a-zA-Z0-9-_]{1,63}):?(\\d{1,5})?$', 'mig')
const str = `.com
a.com
aa.com
a.a.com
a.a.a.com
Domain-123.com
subDomain.Domain-123.com
test.subDomain.Domain-123.com
Domain-123.com:12345
subDomain.Domain-123.com:12345
test.subDomain.Domain-123.com:12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}