import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9-_]{0,63}\\.?[a-zA-Z0-9-_]{1,63}\\.[a-zA-Z0-9-_]{1,63}):?(\\d{1,5})?$";
final String string = ".com\n"
+ "a.com\n"
+ "aa.com\n"
+ "a.a.com\n"
+ "a.a.a.com\n\n"
+ "Domain-123.com\n"
+ "subDomain.Domain-123.com\n"
+ "test.subDomain.Domain-123.com\n\n"
+ "Domain-123.com:12345\n"
+ "subDomain.Domain-123.com:12345\n"
+ "test.subDomain.Domain-123.com:12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}