package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-zA-Z0-9-_]{0,63}\.?[a-zA-Z0-9-_]{1,63}\.[a-zA-Z0-9-_]{1,63}):?(\d{1,5})?$`)
var str = `.com
a.com
aa.com
a.a.com
a.a.a.com
Domain-123.com
subDomain.Domain-123.com
test.subDomain.Domain-123.com
Domain-123.com:12345
subDomain.Domain-123.com:12345
test.subDomain.Domain-123.com:12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}