using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9-_]{0,63}\.?[a-zA-Z0-9-_]{1,63}\.[a-zA-Z0-9-_]{1,63}):?(\d{1,5})?$";
string input = @".com
a.com
aa.com
a.a.com
a.a.a.com
Domain-123.com
subDomain.Domain-123.com
test.subDomain.Domain-123.com
Domain-123.com:12345
subDomain.Domain-123.com:12345
test.subDomain.Domain-123.com:12345";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}