use strict;
my $str = '.com
a.com
aa.com
a.a.com
a.a.a.com
Domain-123.com
subDomain.Domain-123.com
test.subDomain.Domain-123.com
Domain-123.com:12345
subDomain.Domain-123.com:12345
test.subDomain.Domain-123.com:12345';
my $regex = qr/^([a-zA-Z0-9-_]{0,63}\.?[a-zA-Z0-9-_]{1,63}\.[a-zA-Z0-9-_]{1,63}):?(\d{1,5})?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}