using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ส[ัา][สด]|สัตว์|เหี้ย";
string input = @"สัด
สาท
สาด
สัตว์
เ หี้ย
ดกเดกเ
ดกเดกเ
กดเกดดเ
พะำ
นรีน
อือเ
ด้พะ
ะด้ด
เด้ดเ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}