// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ส[ัา][สด]|สัตว์|เหี้ย").unwrap();
let string = "สัด
สาท
สาด
สัตว์
เหี้ย
ดกเดกเ
ดกเดกเ
กดเกดดเ
พะำ
นรีน
อือเ
ด้พะ
ะด้ด
เด้ดเ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}