use strict;
my $str = 'สัด
สาท
สาด
สัตว์
เหี้ย
ดกเดกเ
ดกเดกเ
กดเกดดเ
พะำ
นรีน
อือเ
ด้พะ
ะด้ด
เด้ดเ';
my $regex = qr/ส[ัา][สด]|สัตว์|เหี้ย/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}