re = /ส[ัา][สด]|สัตว์|เหี้ย/m
str = 'สัด
สาท
สาด
สัตว์
เหี้ย
ดกเดกเ
ดกเดกเ
กดเกดดเ
พะำ
นรีน
อือเ
ด้พะ
ะด้ด
เด้ดเ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end