package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ส[ัา][สด]|สัตว์|เหี้ย`)
var str = `สัด
สาท
สาด
สัตว์
เหี้ย
ดกเดกเ
ดกเดกเ
กดเกดดเ
พะำ
นรีน
อือเ
ด้พะ
ะด้ด
เด้ดเ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}